Reasons Why The COVIDSafe App May Not Install

You maybe trying to install the COVIDSafe app on your smartphone and are unable to get it to install.

One of the issues we have seen with the COVIDSafe app are people that own old Android phones that have a version of Android that is too old.

For Android, you need Android 6.0 (Marshmallow) or higher.

For iOS, you need iOS 10 or higher. You will need an iPhone 5S model phone or higher.

We are currently up to Android version 10 and iOS 13

Android users appear to be a bit more reluctant to update their operating systems on their phones and updates are usually only sent for 2 – 3 years .

Check your Android phone by going into settings and look to see if you have updates to the operating system.

And remember:

Author: Adelaide Techguy

Richard Pascoe is a technology consultant & technology commentator for the media on FIVEaa , ABC Adelaide , PowerFM , 5MU , 7AD and 7BU and has been seen on the Channel 7 news , Channel 9 News , Channel 10 news and Today Tonight . Richard gives his opinions on Microsoft , Google , Apple and deals with personal computers , smartphones and tablets.

Leave a Reply